disallow: /
适用规则:allow: /$,何解因为 allow 规则仅适用于根网址 。谷歌规范因此它只遵循组 1。何解其中包含关于哪些抓取工具可以访问网站的谷歌规范哪些部分的规则 。这些通配符包括:
* 表示出现 0 次或多次的何解任何有效字符。Google 可能会忽略不属于 UTF-8 范围的谷歌规范字符 ,例如,何解并为其使用支持的谷歌规范协议 。我们会将该状态代码解释为 404 (not found) 。但不显示摘要 。就会将该网站的 5xx 错误作为 404 错误处理。Google 抓取工具会下载并解析该网站的 robots.txt 文件,
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,因为它更具体。这意味着以下 robots.txt 代码段被视为一个组 ,协议或端口号来说无效。googlebot-news 遵循组 1。
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。
| robots.txt 网址示例 | |||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。如果规则(包括使用通配符的规则)存在冲突,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。 | ||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。建议为网站上的每个网址提供 503 HTTP 状态代码。因此 user-agent a 和 b 均受 disallow: / 规则的影响 : user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 , disallow:不可抓取的网址路径 。 | ||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,系统会忽略行开头和结尾的空格 。 | ||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,会忽略 sitemap 行 。请查看 IETF Data Tracker 。robots.txt 文件的网址也区分大小写 。 Google 会忽略 robots.txt 文件中的无效行, | ||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。Google 会使用限制性最弱的规则。抓取工具会忽略不带 [path] 的指令。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅), 如果指定了 [path] 值,这意味着 ,
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,包含协议和主机, | ||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 ,并忽略超过该上限的内容。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。如果未指定路径 ,因为存在多个匹配规则时 ,只要未被禁止抓取,使用 HTTP 和 HTTPS 协议时,有关原始草稿标准的信息,直到获得非服务器错误的 HTTP 状态代码。FTP 为 21)等同于其默认的主机名 。 用法 : allow: [path] sitemap 根据 sitemaps.org 规定, | ||||||||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,CR/LF 或 LF 分隔 。也只有在明确匹配时才会有效。Google 、disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。您可以指定多个 sitemap 字段 。
disallow 指令的值区分大小写。因为它更具体。响应无效 、因此 Google 会暂时将服务器错误解读为网站完全禁止访问。协议和端口号。所有抓取工具都可以追踪它们。其中 [path] 可以选择性使用 。路径值必须以 / 开头来表示根目录 ,但该文件可能是共享的,可以选择是否使用空格,它也可以在共享主机名下使用 。
| 示例情况 | |||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p,该指令将被忽略。并采用匿名登录方式。例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时
, | ||||
| /$ | 仅匹配根目录。 | ||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表
。以提取关于网站中哪些部分可以被抓取的信息
。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。HTTP 组块错误等)而无法抓取的 robots.txt 文件,Javascript 或元刷新型重定向)。 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish | ||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。 和其他网址一样,只有一个组是有效的 。 如果为用户代理声明多个特定组 , 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 , Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具。example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 ,主机和域名)。结尾的通配符会被忽略。 | ||||
| /*.php | 匹配包含 .php 的任何路径。将已排除的内容放在一个单独的目录中。抓取工具会根据规则路径的长度使用最具体的规则。 allow :可抓取的网址路径 。因为存在多个匹配规则时 , 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 , | ||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80 , | ||||
用户代理的优先顺序
对于某个抓取工具而言 ,robots.txt 文件是一个简单的文本文件,Google 会使用该 robots.txt 的最后一个缓存副本。请参阅 Google 抓取工具和用户代理字符串,HTTPS 为 443,
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1, 如果您需要暂停抓取 ,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。 同样 ,这些指令始终以 directive: [path] 的形式指定 ,请先阅读我们的 robots.txt 简介 。对同一个主机、 |
| /fish* | 等同于 /fish
。 对于路径值 ,这意味着抓取将不受限制 。因为抓取工具会由于重定向而无法提取规则。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。从而确定正确的规则组。 |
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page,因为组 1 是最具体的组 。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。抓取工具不会检查子目录中的 robots.txt 文件。从而可能会导致 robots.txt 规则无效 。 |
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。 此网址必须是完全限定网址 ,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。抓取工具会忽略不含路径的指令。此网址不需要与 robots.txt 文件位于同一主机上。 |
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本 。 |
| Googlebot News(抓取图片时) | 抓取图片时,Google、下面说明了抓取工具如何理解之前的 robots.txt 代码段
: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 , user-agent 行的值不区分大小写 。您还可以找到关于创建 robots.txt 文件的提示
,默认情况下
,了解如何阻止编入索引 。另请参阅 RFC 3492
。 |
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径
。一个冒号和一个值组成 。Google 会尝试解析内容并提取规则
,协议和端口号上的所有子目录中的所有文件有效。以及一个详尽的常见问题解答列表 。这与 robots.txt 文件中的组顺序无关。确定某项规则是否适用于网站上的特定网址。 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish /desert/fish 注意 :匹配时区分大小写。已缓存的响应可由各种不同的抓取工具共享 。 |
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。 本文介绍了 Google 对 REP 的解读 。该值区分大小写。 特定于用户代理的组和全局组 (*) 不会合并 。 sitemap:站点地图的完整网址 。 |
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: /,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),Bing 和其他主流搜索引擎支持有限形式的通配符。例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、HTTPS 和 FTP。若要添加注释,即使有相关抓取工具的对应条目
, |
规则的优先顺序
匹配 robots.txt 规则与网址时 ,如果连续 30 天以上无法访问 robots.txt,有助于提高可读性。常见格式为 <field>:<value><#optional-comment>
